API errors
Incident Report for Server Density
Postmortem

On October 5th between 14:20 and 14:50 our api.serverdensity.io/alerts was unavailable to requests.

This was caused by a networking failure at our provider that prevented traffic to be routed to the impacted service. Server Density is comprised of multiple micro-services, each of those behind a load balancing device pair sharing a virtual IP address. Traffic to this virtual address is guaranteed by our provider networking infrastructure.

While we are still working with our provider to help them find the root cause of this particular failure, we have reduced our alerting wait time so we are faster to manually re-route traffic in case of a re-occurrence. We will share the conclusions of that analysis as soon as they become available.

Also, we are currently close to completing a project that will change how this traffic is routed to each service that will remove the virtual IP address routing dependency.

Posted Oct 10, 2017 - 13:03 BST

Resolved
We have confirmed this is now resolved.
Posted Oct 05, 2017 - 16:05 BST
Identified
We've identified a networking failure in one of our services and manually failed over. The errors we were measuring are now gone.
Posted Oct 05, 2017 - 16:01 BST
Investigating
We're investigating api.serverdensity.io elevated error rate.
Posted Oct 05, 2017 - 15:41 BST